Livro

LANÇAMENTO !!! Meu livro “Informática para Concursos – Teoria e Questões”, 3a edição, editora FERREIRA.

Link: https://www.editoraferreira.com.br/1/47/176/224/editora-ferreira/livros/informatica-para-concursos/

31 de dezembro de 2008

ICMS/RJ 2008 Q.60 Business Intelligence (BI) ...

Business Intelligence (BI) refere-se ao processo para tomada de decisões em uma empresa, sendo de elevada importância a existência de um repositório próprio para os dados consolidados e já transformados em "informação real", que pode ser um Data Warehouse ou um Data Mart. Nesse contexto, duas aplicações são identificadas: a primeira, que sustenta o negócio por meio de ferramentas OLTP(On Une Transaction Processing), e a segunda, que analisa o negócio por meio de ferramentas OLAP(On Une Analytical Processing). Essas aplicações têm, como objetivos principais, respectivamente:
a) levantamento e armazenamento de dados/ implementação de testes.
b) controle e registro de transações/identificação de tendências.
CORRETO
c) projeto e análise de sistemas/transformação de processos.
d) pesquisa e teste de software/especificação de requisitos.
e) busca e coleta de informações/substituição de rotinas.
A primeira, que sustenta o negócio por meio de ferramentas OLTP (Online Transaction Processing) – Processamento de Transações Online . Ex. Sistema de reserva de passagem aérea. E a segunda, que analisa o negócio por meio de ferramentas OLAP (On Line Analytical Processing) são aplicações utilizadas pelos usuários finais (gerentes, executivos e analistas) para extração de dados com os quais geram relatórios capazes de responder às questões gerenciais. Eles surgiram junto com os sistemas de apoio à decisão para possibilitar a extração e análise dos dados contidos nos Data Warehouse e nos Data Marts. Através de acesso rápido e interativo, os usuários obtém uma ampla variedade de possibilidades de visão da informação. A funcionalidade OLAP é caracterizada pela análise dinâmica multi-dimensional (em formato de cubo) dos dados consolidados da corporação, auxiliando o usuário a sintetizar as informações de forma personalizada. Podem ser feitas consultas "ad-hoc", em que o próprio usuário trata os dados de acordo com suas necessidades e métodos que lhe permitem descobrir o que procura. A análise multi-dimensional é uma das grandes utilidades da tecnologia OLAP na medida em que possibilita visualizar determinados cubos (massas de dados que retornam das consultas feitas ao banco de dados) de informações sob diferentes ângulos e vários níveis de agregação. Uma das funcionalidades mais importantes do OLAP é a chamada "slice and dice" que permite analisar as informações sob diferentes prismas, como se o usuário as estivesse fatiando e cortando em cubos. Com as funcionalidades Drill Down e o Drill Up o usuário pode subir e descer dentro do detalhamento do dado, ou seja, partindo da mesma base de dados, é possível analisar uma informação tanto diariamente, quanto anualmente. A geração de Queries (consultas) no OLAP é feita de maneira simples, amigável e transparente, não exigindo dos usuários grandes conhecimentos de informática. Com a evolução da tecnologia surgiram outras ferramentas da família OLAP. A DOLAP (Desktop On Line Analytical Processing) é uma solução que dispara uma instrução SQL de uma estação cliente qualquer para o servidor, recebendo de volta um microcubo de informações que poderão ser analisadas na workstation. Dessa forma, todo o processamento OLAP acontece na máquina cliente, liberando o servidor de banco de dados, diminuindo o risco deste ficar sobrecarregado e permitindo maior agilidade de análise. A única desvantagem é o tamanho do microcubo que não pode ser muito grande. As ferramentas ROLAP (Relational On Line Analytical Processing) possibilitam que a consulta seja enviada e processada no banco de dados relacional. Nesse caso, o processamento OLAP ocorre somente no servidor, o que permite a análise de grandes volumes de dados. Outra ferramenta é a MOLAP (Multidimensional On Line Analytical Processing) em que o usuário trabalha, monta e manipula os dados do cubo diretamente no servidor multidimensional, o que aumenta a perfomance. A mais recente ferramenta é a HOLAP (Hybrid On Line Analytical Processing), uma combinação entre as soluções ROLAP e MOLAP que procura utilizar o que há de melhor de cada uma delas: a alta performance do MOLAP com a maior escalabilidade do ROLAP.

29 de dezembro de 2008

ICMS/RJ 2008 Q.59 No funcionamento de um sistema de gerenciamento de banco de dados, uma situação de falha....

No funcionamento de um sistema de gerenciamento de banco de dados, uma situação de falha ocorre quando dois usuários tentam alterar, simultaneamente, um mesmo registro. Por exemplo, no caso de dois clientes de uma empresa de cartões de crédito tentarem realizar, num dado instante, a liquidação de um mesmo boleto da mesma fatura, um deles receberá uma mensagem de falha. A situação descrita é conhecida por:
a) Multlock.
b) Crashing.
c) Overlock.
d) Locking.
e) Deadlock.
CORRETO
O deadlock ocorre com um conjunto de processos e recursos, ou seja, onde um ou mais processos desse conjunto está aguardando a liberação de um recurso por um outro processo que, por sua vez, aguarda a liberação de outro recurso alocado ou dependente do primeiro processo. Crashing (colisão)

28 de dezembro de 2008

ICMS/RJ 2008 Q.56 Excel ... a) =SE(E7>=$E$18;”Atingiu meta!”;”Abaixo da meta!”) e =SOMASE($C$7:$C$16;G21;$E$7:$E$16)

Analise a planilha abaixo, criada por um Fiscal de Rendas, no Excel 2003 BR.

Na utilização dos recursos do software, o Fiscal executou os seguintes procedimentos, em seqüência:
I. Inseriu fórmulas nas células de G7 a G16, para escrever “Atingiu meta!” se a pontuação foi maior ou igual à média do mês e “Abaixo da meta!”, caso contrário.
II. Inseriu, na célula H19, a expressão =SOMASE ($C$7:$C$16;G19;$E$7:$E$16).
III. Selecionou a célula H19 e executou o atalho de teclado + C.
IV. Selecionou a célula H21 e executou o atalho de teclado + V.

Para obtenção dos resultados indicados, as fórmulas inseridas nas células H7 e H21 são, respectivamente:
a) =SE(E7>=$E$18;”Atingiu meta!”;”Abaixo da meta!”) e =SOMASE($C$7:$C$16;G21;$E$7:$E$16) (correta)
b)
=SE(E7>=$E$20;”Atingiu meta!”;”Abaixo da meta!”) e =SOMASE($C$9:$C$18;G21;$E$9:$E$18)
c) =SE(E7>=$E$18;”Abaixo da meta!”;”Atingiu meta!”) e =SOMASE($C$9:$C$18;G21;$E$9:$E$18)
d) =SE(E7>$E$20;”Abaixo da meta!”;”Atingiu meta!”) e =SOMASE($C$7:$C$16;G21;$E$7:$E$16)
e) =SE(E7>$E$18;”Atingiu meta!”;”Abaixo da meta!”) e =SOMASE($C$7:$C$16;G21;$E$7:$E$16)

Questão como essa gosto de resolver na máquina e capturar as telas, passo a passo.
Passo 1
I. Inseriu fórmulas nas células de G7 a G16, para escrever “Atingiu meta!” se a pontuação foi maior ou igual à média do mês


e “Abaixo da meta!”, caso contrário.

Passo 2
II. Inseriu, na célula H19, a expressão =SOMASE ($C$7:$C$16;G19;$E$7:$E$16).


Passo 3
III. Selecionou a célula H19 e executou o atalho de teclado + C.
IV. Selecionou a célula H21 e executou o atalho de teclado + V.